Waffenkostüm geht nicht mehr in den Slot rein

In this section, threads need to be marked as resolved by the thread creator, if the question has been answered or the problem has been solved. After this the thread will be closed automatically.
Just click on "Edit Thread > Mark as Resolved".
  • Nabend,


    hab momentan folgendes Problem, warum auch immer.


    Also, nachdem ich das Petkostüm-Slot eingefügt habe, funktioniert das Waffenkostümsystem nicht mehr.

    Hab das Petkostüm-Slot erneut ausgebaut um zu testen ob es danach funktioniert, leider auch ohne Erfolg. (sind alte Einstellungen wo es vorher ging)


    Ich hab an dem Code, welches ich für das Waffenkostüm System einbauen musste, nicht verändert.


    Ich hoffe jemand kann mir wegen meinem Problem helfen.


    Ich hab bereits in der GameType.h den c_equipment_start erhöht, niedriger gesetzt etc. alles versucht.

    Das Waffenkostüm-System hab ich auch nochmal komplett neu verbaut, leider auch ohne Erfolg.


    Hier die wichtigsten Dateien (falls weitere benötigt werden, kann ich diese gerne nachreichen):

    Code: GameType.h (Client Source) - NEW EQUIPMENT
    1. #ifdef ENABLE_NEW_EQUIPMENT_SYSTEM
    2. const DWORD c_New_Equipment_Start = c_Equipment_Start + 22;
    3. const DWORD c_New_Equipment_Count = 3;
    4. const DWORD c_Equipment_Ring1 = c_New_Equipment_Start + 0; // 22
    5. const DWORD c_Equipment_Ring2 = c_New_Equipment_Start + 1; // 23
    6. const DWORD c_Equipment_Belt = c_New_Equipment_Start + 2; // 24
    7. const DWORD c_New_Equipment_End = c_New_Equipment_Start + c_New_Equipment_Count;
    8. #endif
    Code: GameType.h (Client Source) - COSTUME SYSTEM
    1. #ifdef ENABLE_COSTUME_SYSTEM
    2. const DWORD c_Costume_Slot_Start = c_Equipment_Start + 19; // 19 [START]
    3. const DWORD c_Costume_Slot_Body = c_Costume_Slot_Start + 0; // 19
    4. const DWORD c_Costume_Slot_Hair = c_Costume_Slot_Start + 1; // 20
    5. #ifdef ENABLE_COSTUME_WEAPON_SYSTEM
    6. const DWORD c_Costume_Slot_Weapon = c_Costume_Slot_Start + 2; // 21
    7. #endif
    8. const DWORD c_Costume_Slot_Count = 3;
    9. const DWORD c_Costume_Slot_End = c_Costume_Slot_Start + c_Costume_Slot_Count;
    10. #endif
    Code: costumewindow.py (Python)
    1.                                         {"index":COSTUME_START_INDEX+0, "x":61, "y":44, "width":32, "height":64},
    2. {"index":COSTUME_START_INDEX+1, "x":61, "y": 8, "width":32, "height":32},
    3. {"index":COSTUME_START_INDEX+2, "x":13, "y":11, "width":32, "height":96},
    4. {"index":item.EQUIPMENT_RING1, "x":61, "y":151, "width":32, "height":32},
    5. {"index":item.EQUIPMENT_RING2, "x":13, "y":152, "width":32, "height":32},


    Ich bin mir sicher, dass es wieder so ein idiotischer Fehler ist worauf ich gerade nicht komme.


    Aber ich komme so auch zu keiner Lösung, daher wollte ich mal hier Nachfragen.



    Liebe Grüße

  • m2u
  • Moderator

    Closed the thread.
  • This threads contains 6 more posts that have been hidden for guests, please register yourself or log-in to continue reading.